4coder»Forums
26 posts
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
Hi Allen,

when using word completion the words are only recognized right before the first non-ascii character (like ä, ö, ü or ß). A name like ZÄHLERSTAND are only recognized up to "Z", DREHSTRÖME only up to "DREHSTR".


Will this be changed later in 4coder?

thanks for the info.
Allen Webster
473 posts / 4 projects
Heyo
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
Thanks, that's a bug, I'll be sure to fix it.
Mārtiņš Možeiko
2278 posts / 2 projects
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
1
2
3
4
bool isLetter(char c)
{
    return c >= 'a' && c <= 'z' || c >= 'A' && c <= 'Z';
}

:)
26 posts
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
Edited by robby on
Hi,

to add - maybe this is related: When using the build command, instead of showing the complete output of the commands, the buffer only shows the exit-code state ("exited with code 0") when the output had any non-ascii characters in it.


UPDATE: Just learned this is not related. Hitting several times ALT+m made different outputs (while not changing the program). Sometimes no output at all, sometimes just the output of the program, most of the times the output with the exit code. Sorry for confusing this! After restarting 4coder this issue was gone (had it running for 4 days).
Allen Webster
473 posts / 4 projects
Heyo
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
@mmozeiko Yes that is the situation haha

@robby That's actually more unusual. I am not sure why that would happen, can you confirm that this wasn't an issue before 4.0.17?
26 posts
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
Hi Allen,

I tested it on earlier versions too. It's not necessarily an issue with 4coder. It's more an issue of the multithreaded program I invoke to write to the output buffer. When I execute the build.bat file multiple times I sometimes get no output at all or everything and anything in between.

I will have to investigate more time on my program, because it involves a jni.h (java virtual machine). I will report when i find anything new.
Allen Webster
473 posts / 4 projects
Heyo
Behavior word-completion stops at non ascii characters (version alpha 4.0.17)
Yeah the output capturing for child processes is not stellar, I can't promise to fix it in the next version but it's on my radar.