4coder»Forums
Anthony Romano
5 posts
i am a man.
error on startup
im getting an error popup when i try to run 4coder

"w:\4ed\code\platform_win32\win32_4ed.cpp:610: OpenGL init fail - wglCreateContextAttribsARB missing"

does this mean i'm not going to be able to use future version of 4coder cus i have a crap onboard video card?
David Butler
81 posts / 1 project
I love pretty much anything technical, whether it be programming, networking, hacking or electronics.
error on startup
Edited by David Butler on
A hack that might work would be to just use a software only version of Mesa, because the build of OpenGL that ships with windows is really old... This is a build that I use to get modern OpenGL on older machines: https://www.dropbox.com/s/9yqsp09jmbhxcct/OpenGL32.dll?dl=0

Download and copy that file into the directory that contains 4ed.exe

Of-course Allen will probably have a better solution...
Anthony Romano
5 posts
i am a man.
error on startup
hey it works! thank you!
David Butler
81 posts / 1 project
I love pretty much anything technical, whether it be programming, networking, hacking or electronics.
error on startup
Nice! no problem :) Btw, if you copy your build to another computer and want to use hardware acceleration, you will need to remove the .dll, so that it will use your GPU vendor's OpenGL implementation.
Allen Webster
473 posts / 4 projects
Heyo
error on startup
Edited by Allen Webster on
Haha glad you were able to hack that in for now. No this will not alway be a problem. Now that the renderer is cleaned up properly, I am planning to start supplying alternate renderers to handle these sorts of problems. So, for instance, if I add a DirectX renderer, then if you are on a windows machine with poor support for OpenGL it will still work.

However that's not my top priority right now, so you'll want to keep Croepha's solution for a little while.
Zenn
19 posts
error on startup
Edited by Zenn on
I have the same problem. And I just bought 4Coder and Handmade Hero yesterday... LOL.

And yes I tried the DLL fix above still no go.

Works ok on my newer desktop but not my older laptop. Brought it out and did a clean install of Windows 7 Pro just to use it for handmade only. Oh well.

Don't know when I will be able to afford a new laptop. Anyone got any ideas? It will only be used for Handmade Hero. Doesn't need to be fancy. Just small enough for when I'm on the go and good enough for Handmade.

Would putting on Ubuntu help? Not that I know how to use anything outside of windows OS. I could learn....

Zenn
19 posts
error on startup
Nevermind I got it. I needed the 32 bit version as that's the only legit copy of windows 7 I have.

So now it works!!! YAY
Allen Webster
473 posts / 4 projects
Heyo
error on startup
Glad you got it working. By the way I only check on the forums every few days. If you contact me at [email protected], you unfortunately won't get the help from everyone else, but I will see it almost every time, and I tend to have an easier time remembering and getting to bug reports that come in there. It's up to you which method you prefer though.