4coder » Forums » Fonts aren't setting correctly
MEXdave1997
David Madrigal-Hernandez
18 posts
#15093 Fonts aren't setting correctly
5 months ago Edited by David Madrigal-Hernandez on April 28, 2018, 6:05 a.m. Reason: Add info and link to previous thread on issue

Hi all!

So, I have been messing around with the command line options for 4Coder, trying to figure out what will work correctly. Currently, I have this:

1
"C:\Program Files\4coder\4ed.exe" -F -S -f12


for launching the program via the command line, and the fullscreen option works. However, the option to set the font size
1
-f 12
does not function. Is there any way to do this in the main 4coder config file that I am missing?

EDIT: As a note, the previous thread on this issue doesn't show me a solution that works for me. :/
ssutherington
simon sutherington
1 posts
#15095 Fonts aren't setting correctly
5 months ago

-f 12 -F -S works fine for me with 4.0.25

It seems that the order is important, the font size first, then the full screen flag, then the -S (whatever that does). Also, note the space between the -f and the size, -f12 appears to not work but -f 12 does.
mrmixer
Simon Anciaux
457 posts
#15097 Fonts aren't setting correctly
5 months ago

-S was required before to go fullscreen, but I believe it isn't used anymore.
Mr4thDimention
Allen Webster
411 posts / 2 projects

Heyo

#15098 Fonts aren't setting correctly
5 months ago Edited by Allen Webster on April 28, 2018, 3:29 p.m.

1. -S is gone in 4.0.25, -F is all you need for full screen.
2. 4coder expects the flag and it's parameter to be separated -f 12 not -f12
3. Order shouldn't matter, if it does that's a bug, I'll take a look.
4. This is not in the 4coder config file at the moment... which is odd! I'll add it next build!
MEXdave1997
David Madrigal-Hernandez
18 posts
#15100 Fonts aren't setting correctly
4 months, 4 weeks ago

Mr4thDimention
1. -S is gone in 4.0.25, -F is all you need for full screen.
2. 4coder expects the flag and it's parameter to be separated -f 12 not -f12
3. Order shouldn't matter, if it does that's a bug, I'll take a look.
4. This is not in the 4coder config file at the moment... which is odd! I'll add it next build!


1. Great. That is one less flag I have to worry about.
2. Also fixed that formatting, didn't notice I did that. :laugh:
3. Yup, definitely a bug. I just tried to reorder the font first, and it indeed work.
4. Glad to hear this is coming in the next build! Glad that I got the super version, and can't wait to update! :)