Register
4coder»Forums»Segfault when using sshfs
3 posts
Segfault when using sshfs
1 year ago Edited by serolod on Oct. 8, 2018, 8:07 a.m. Reason: Initial post
Hi all,

I was trying out the demo and tried opening a file hosted on another machine via sshfs. While tabbing into the folder, 4ed segfaulted. I ran it through gdb once, here is the relevant output:
1
2
3
4
Thread 1 "4ed" received signal SIGSEGV, Segmentation fault.
view_set_file ([email protected]=0x7bd0c0 <sysfunc>, [email protected]=0x7ffff3a4d000, 
    [email protected]=0x7ffff3a81910, file=0x7ffff3a8f6b0)
    at /home/allen/4ed/code/4ed_view.cpp:390


The software I used:
4ed 4.028
SSHFS version 3.5.0
FUSE library version 3.2.6
using FUSE kernel interface version 7.26
fusermount3 version: 3.2.6
linux 4.18

Hope this helps and all the best!
Allen Webster
477 posts / 2 projects

Heyo

Segfault when using sshfs
1 year ago
Thanks for all the info, this will help, I'll let you know when I know more about this.
3 posts
Segfault when using sshfs
6 months, 2 weeks ago
I tested this again with 4.0.30 and the crash is gone, but tabbing into folders mounted with sshfs does not work as expected. Suppose you have a folder test with
1
2
3
4
5
6
7
test
├── regular
│   └── a
│       └── foo.txt
└── sshfs
    └── b
        └── bar.txt

where sshfs is mounted from remote. Start 4ed in test, then ctrl+o -> r -> tab -> tab -> tab and foo.txt gets loaded. If on the other hand you do ctrl+o -> s -> tab -> tab it does not change into b after the second tab, but exits file opening mode and returns to whatever buffer you had loaded.