2 posts
Text wrapping not working in code?
Edited by mamoniot on Reason: Initial post
Hello, I'm new to 4coder, and I'm having an issue with getting text wrapping to work in the demo version. I prefer text to be wrapped always so that no text can trail off the right of the screen. 4coder seems to do this, with an option in the configuration file, but it doesn't seem to be working on code. So for whatever reason plain text files get text wrapping, but not code files.

These are my current settings in the configuration file. I've tried changing them but nothing seems to enable text wrapping for code.
// Code Wrapping
treat_as_code = ".cpp.c.h.hpp.cc.hh.cs.java.rs.glsl.m";
enable_virtual_whitespace = true;
enable_code_wrapping = true;
automatically_adjust_wrapping = true;
default_wrap_width = 672;
default_min_base_width = 550;
Victor Caraulan
1 posts
Text wrapping not working in code?
What you can do is press "alt + x" and then write toggle_line_wrap and press enter. That's the way you use the commands 4coder has manually.
I think that the reason why it doesn't take into account the config preferences is because you use 4coder with a file as an argument, but I'm not sure about that.
Allen Webster
473 posts / 4 projects
Text wrapping not working in code?
To double check, on startup I believe 4coder should be printing your configuration out to the *messages* buffer. Can you check there to see if the configuration 4coder reports matches what you're trying to put into it? It's possible something has gone wrong either in finding the file or parsing it.
2 posts
Text wrapping not working in code?
The message does have the configuration in it, and those configuration do match what I write in the config file.