Register
4coder»Forums»Is this still a bug?
Jason
176 posts
Is this still a bug?
6 months, 1 week ago Edited by Jason on March 14, 2020, 3:56 p.m. Reason: Initial post
I know there was a bug in earlier versions of 4coder with binding modifiers to commands (I think the order of modifiers was causing some unintended issues or something) which meant I had to do something like this in my custom mapping file:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
MappingScope();
SelectMapping(mapping);

SelectMap(global_id);
BindCore(jason_default_startup, CoreCode_Startup);
BindCore(default_try_exit, CoreCode_TryExit);
Bind(interactive_open_or_new, KeyCode_Control, KeyCode_O); //This gets overridden below
..........

SelectMap(file_id);
ParentMap(global_id);
BindTextInput(write_text_input);
.........

SelectMap(code_id);
ParentMap(file_id);
BindTextInput(write_text_and_auto_indent);
Bind(jason_insert_newline_below, KeyCode_O); //This Binding overwrites the Control+O for interactive_open_new command

Bind(interactive_open_or_new, KeyCode_Control, KeyCode_O); //Meaning I have to paste this again here


In the most recent version (4.1.4) one of the changes says:

"Bindings use exact matches for modifiers, instead of most recent sub-set matches"

I thought this would fix the above issue but it has not. Is this still a bug or am I just not using my custom mappings correctly?
Allen Webster
483 posts / 2 projects

Heyo

Is this still a bug?
6 months, 1 week ago
Yes this issue was fixed for the order of bindings within a map, but it still doesn't work for inherited bindings. This was just an oversight of the fix and will be fully fixed in the next build.
Jason
176 posts
Is this still a bug?
6 months ago Edited by Jason on March 16, 2020, 5:25 p.m.
Oh okay cool. Thanks allen