4coder » Forums » Hotkeys are not working when non-English keyboard layout is selected.
Fothsid
Fedor Vorobyev
2 posts

ლ(ಠ_ಠლ)

#20598 Hotkeys are not working when non-English keyboard layout is selected.
1 month, 3 weeks ago Edited by Fedor Vorobyev on Feb. 25, 2019, 7:43 a.m.

Title speaks for itself.
Bought 4coder yesterday and this is what I immediatly ran into, since my main keyboard layout is Cyrillic :^)
mrmixer
Simon Anciaux
582 posts
#20599 Hotkeys are not working when non-English keyboard layout is selected.
1 month, 3 weeks ago

You can have a look there to customize your keys: Customization layer - getting started.

And since I didn't add it to the thread, there is a way to remap only the keys you want.

If you make a "standard" Cyrillic key config, you could share it here for other to use.
Fothsid
Fedor Vorobyev
2 posts

ლ(ಠ_ಠლ)

#20600 Hotkeys are not working when non-English keyboard layout is selected.
1 month, 3 weeks ago

By "main keyboard layout is Cyrillic" I mean that in my system, Cyrillic is a primary layout and defaults to it every time I run any program. Plus I'm constantly switching (mostly using Alt+Shift Windows' hotkey) between English and Cyrillic layouts during coding and, for example, writing text in Russian, and I need hotkeys working with both keyboard layouts, as far as I understand, it has nothing to do with customizing hotkeys.
mrmixer
Simon Anciaux
582 posts
#20602 Hotkeys are not working when non-English keyboard layout is selected.
1 month, 3 weeks ago Edited by Simon Anciaux on Feb. 25, 2019, 5:43 p.m. Reason: typo

4coder uses virtual key codes for setting up hotkeys, so it will not be able to have a hotkey with a Cyrillic letter do the same thing as a Roman letter unless you set both hotkeys. It's not going to be fun but you'll need to set two hotkeys for each command you want to use.

If you call default_keys(context); in your startup hook, you can than just bind keys in Cyrillic and you should get both shortcuts working.
Mr4thDimention
Allen Webster
469 posts / 2 projects

Heyo

#20604 Hotkeys are not working when non-English keyboard layout is selected.
1 month, 3 weeks ago

Unfortunately keyboard input handling is not sophisticated enough for what you're trying to do right now. Fixing this is in my 2019 road map, and I'm hoping to get to it sooner rather than later, once this final round of major feature upgrades goes out, that will be one of my main priorities.